pkgbuilds/kpeoplevcard-git/PKGBUILD

31 lines
633 B
Bash

# Maintainer: Rihards Skuja <rhssk at posteo eu>
_pkgname=kpeoplevcard
pkgname=$_pkgname-git
pkgver=0.1.r139.g73c8f5f
pkgrel=2
pkgdesc='Expose VCard contacts to KPeople'
arch=(x86_64)
url='https://kde.org'
license=(GPL)
depends=(kpeople kcontacts)
makedepends=(git extra-cmake-modules)
provides=($_pkgname)
conflicts=($_pkgname)
source=("git+https://invent.kde.org/pim/$_pkgname.git")
md5sums=('SKIP')
pkgver() {
cd $_pkgname
git describe --long --abbrev=7 | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
cmake -B build -S $_pkgname -Wno-dev
cmake --build build
}
package() {
DESTDIR="$pkgdir" cmake --install build
}